blob: 45eed0e043b8683136a510f64c82637620d75271 [file] [log] [blame]
Damien Zammit06853222016-11-16 21:06:54 +11001#
2# Copyright (C) 2014 Steve Shenton <sgsit@libreboot.org>
3# Leah Rowe <info@minifree.org>
4# Copyright (C) 2017 Damien Zammit <damien@zamaudio.com>
5#
6# This program is free software: you can redistribute it and/or modify
7# it under the terms of the GNU General Public License as published by
8# the Free Software Foundation, either version 3 of the License, or
9# (at your option) any later version.
10#
11# This program is distributed in the hope that it will be useful,
12# but WITHOUT ANY WARRANTY; without even the implied warranty of
13# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14# GNU General Public License for more details.
15
16#
17# Datasheets:
18#
19# http://www.intel.co.uk/content/dam/doc/application-note/i-o-controller-hub-9m-82567lf-lm-v-nvm-map-appl-note.pdf
20# https://communities.intel.com/community/wired/blog/2010/10/14/how-to-basic-eeprom-checksums
21
22# The datasheet says that this spec covers the following pci ids:
23# 8086:10F5 - Intel 82567LM gigabit ethernet controller
24# 8086:10BF - Intel 82567LF gigabit ethernet controller
25# 8086:10CB - Intel 82567V gigabit ethernet controller
26
27# GbE SPEC for ICH9M (82567LM/LF/V)
28{
29 "macaddress"[6] : 8,
30 "ba_reserved1_0" : 8,
31 "ba_reserved1_1" : 3,
32 "ba_ibootagent" : 1,
33 "ba_reserved2" : 4,
34 "reserved04" : 16,
35 "version05" : 16,
36 "reserved06" : 16,
37 "reserved07" : 16,
38 "pbalow" : 16,
39 "pbahigh" : 16,
40 "pci_loadvid" : 1,
41 "pci_loadssid" : 1,
42 "pci_reserved1" : 1,
43 "pci_reserved2" : 3,
44 "pci_pmen" : 1,
45 "pci_auxpwr" : 1,
46 "pci_reserved3" : 4,
47 "pci_reserved4" : 4,
48 "ssdid" : 16,
49 "ssvid" : 16,
50 "did" : 16,
51 "vid" : 16,
52 "devrevid" : 16,
53 "lanpwr_d3pwr" : 5,
54 "lanpwr_reserved" : 3,
55 "lanpwr_d0pwr" : 8,
56 "reserved11" : 16,
57 "reserved12" : 16,
58 "sh_reserved1" : 3,
59 "sh_force_halfduplex" : 1,
60 "sh_force_lowspeed" : 1,
61 "sh_reserved2_0" : 3,
62 "sh_reserved2_1" : 1,
63 "sh_phy_enpwrdown" : 1,
64 "sh_reserved3" : 1,
65 "sh_reserved4" : 3,
66 "sh_sign" : 2,
67 "cw1_extcfgptr" : 12,
68 "cw1_oemload" : 1,
69 "cw1_reserved1" : 1,
70 "cw1_reserved2" : 1,
71 "cw1_reserved3" : 1,
72 "cw2_reserved" : 8,
73 "cw2_extphylen" : 8,
74 "extcfg16" : 16,
75 "l1_led1mode" : 4,
76 "l1_reserved1" : 1,
77 "l1_led1fastblink" : 1,
78 "l1_led1invert" : 1,
79 "l1_led1blinks" : 1,
80 "l1_reserved2" : 1,
81 "l1_lplu_all" : 1,
82 "l1_lplu_non_d0a" : 1,
83 "l1_gbedis_non_d0a" : 1,
84 "l1_reserved3" : 2,
85 "l1_gbedis" : 1,
86 "l1_reserved4" : 1,
87 "l02_led0mode" : 4,
88 "l02_reserved1" : 1,
89 "l02_led0fastblink" : 1,
90 "l02_led0invert" : 1,
91 "l02_led0blinks" : 1,
92 "l02_led2mode" : 4,
93 "l02_reserved2" : 1,
94 "l02_led2fastblink" : 1,
95 "l02_led2invert" : 1,
96 "l02_led2blinks" : 1,
97 "reserved19" : 16,
98 "reserved1a" : 16,
99 "reserved1b" : 16,
100 "reserved1c" : 16,
101 "reserved1d" : 16,
102 "_82567lm" : 16,
103 "_82567lf" : 16,
104 "reserved20" : 16,
105 "_82567v" : 16,
106 "reserved22_"[14] : 16,
107 "pxe30_protocolsel" : 2,
108 "pxe30_reserved1" : 1,
109 "pxe30_defbootsel" : 2,
110 "pxe30_reserved2" : 1,
111 "pxe30_ctrlsprompt" : 2,
112 "pxe30_dispsetup" : 1,
113 "pxe30_reserved3" : 1,
114 "pxe30_forcespeed" : 2,
115 "pxe30_forcefullduplex" : 1,
116 "pxe30_reserved4" : 1,
117 "pxe30_efipresent" : 1,
118 "pxe30_pxeabsent" : 1,
119 "pxe31_disablemenu" : 1,
120 "pxe31_disabletitle" : 1,
121 "pxe31_disableprotsel" : 1,
122 "pxe31_disablebootorder": 1,
123 "pxe31_disablelegacywak": 1,
124 "pxe31_disableflash_pro": 1,
125 "pxe31_reserved1" : 2,
126 "pxe31_ibootagentmode" : 3,
127 "pxe31_reserved2" : 3,
128 "pxe31_signature" : 2,
129 "pxe32_buildnum" : 8,
130 "pxe32_minorversion" : 4,
131 "pxe32_majorversion" : 4,
132 "pxe33_basecodeabsent" : 1,
133 "pxe33_undipresent" : 1,
134 "pxe33_reserved1" : 1,
135 "pxe33_efiundipresent" : 1,
136 "pxe33_reserved2_0" : 4,
137 "pxe33_reserved2_1" : 6,
138 "pxe33_signature" : 2,
139 "pxe_padding"[11] : 16,
140 "checksum_gbe" : 16,
141 "padding"[0xf80] : 8
142}