blob: 88a67dcef4fcfde8106912430d9b8f9d24787d11 [file] [log] [blame]
Crabtuxb9402252024-02-20 17:37:12 +08001with import <nixpkgs> {};
2
3pkgs.mkShell {
4 name = "coreboot-devshell-i386";
5
6 packages = [
7 cacert
8 gdb
9 git
10 qemu
11 ];
12
13 buildInputs = [
14 ncurses
15 openssl
16 ];
17
18 nativeBuildInputs = [
19 coreboot-toolchain.i386
20 pkg-config
21 openssh
22 ];
23
24 shellHook = ''
25 # In Nix, stdenv sets a STRIP environment variable, which has conflict
26 # with libpayload/Makefile.payload. Unset the variable.
27 unset STRIP
28 '';
29}